Startseite Foren Anforderungen Infrastructure Administrator stürzt bei Klick auf Profil-Designer ab

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Autor
    Beiträge
  • Jens.Kuegl
    Teilnehmer
    Beitragsanzahl: 5

    Support-ID: 20587081
    Entwickler-ID: M3D-5763

    Beschreibung:
    Der Infrastructure Administrator stürzt bei Klick auf Profil-Designer ab.

    Beispiel/Erläuterung:
    Bei einem geladenen Unternehmensprojekt kommt es sofort zu einem Absturz bei Klick im Navigationsbaum auf (Unternehmensprojekt > Fachschale) > Profil-Designer.
    Das Problem tritt auf, wenn das Modul Profil-Designer nicht aktiviert ist. Wenn der Anwender „ausversehen“ auf Profil-Designer klickt (anstatt z.B. auf Formular-Designer) kommt zum Absturz.
    Wenn das Modul aktiviert ist, tritt das Problem nicht auf (auch wenn kein Profil definiert wurde).
    Zuletzt beobachtet in Version 2023.

    Mögliche Lösungen:
    – Bei Klick auf Profil-Designer stürzt das Programm nicht mehr ab.
    – Wenn das Modul Profil-Designer nicht aktiviert ist, wird der Punkt Profil-Designer im Navigationsbaum ausgeblendet, so dass er nicht mehr angeklickt werden kann.

    Gorden Kock
    Administrator
    Beitragsanzahl: 34

    Hallo Jens,

    Voraussetzung dafür, dass der Profil-Designer überhaupt im Admin auftaucht, ist die einmalige Aktivierung der Profil-Extension im jeweiligen Projekt. Also gehe ich davon aus, dass du das zuerst getan, aber danach die Extension wieder deaktiviert hast. Ist das richtig? Da kommt bei mir die Frage auf, ob die Forderung vielleicht lauten sollte, dass Extensions durch Entfernen des Hakens nicht nur deaktiviert, sondern auch wieder gelöscht werden sollten? Dann würde das Problem ja sicherlich auch nicht auftreten. Oder gibt es einen Grund das Datenmodell behalten zu wollen, aber die Funktionalität an sich zu deaktivieren?

    BTW: vorbildlicher Post mit allen Angaben, vielen Dank!

    Jens.Kuegl
    Teilnehmer
    Beitragsanzahl: 5

    Hallo Gorden,

    danke für die Rückmeldung. Wir haben (mit einer Ausnahme) in keiner Fachschale Profile definiert, aber der Menüpunkt taucht überall auf. Ob vor x Jahren in diesen Fachschalen jemand das Modul aktiviert und anschließend deaktiviert hat kann ich nicht sagen. Ich hatte angenommen, dass der Menüpunkt einfach immer da ist.

    Nach verschiedenen Tests würde ich das Problem jetzt auch anders beschreiben, bzw. zur Problembeschreibung noch ergänzen:
    „Das Problem tritt nur auf, wenn das Modul Profil-Designer eine ältere Version als die aktuell zum Map3D passende Version hat.“

    Test mit neuer Fachschale:
    – neues Projekt und neue Fachschale anlegen
    – Modul aktivieren
    – Modul deaktivieren
    – kein Absturz bei Klick auf Menüpunkt

    Test mit ursprünglich mit 2016 erstellten Fachschale in 2023:
    – Modul ist deaktiviert
    – Absturz bei Klick auf Menüpunkt
    – Modul aktivieren, jetzt kommt „Module und Datenmodell aktualisieren“
    – Modul deaktivieren
    – kein Absturz bei Klick auf Menüpunkt

    In Summe kann ich damit jetzt gut leben. Ich aktualisiere überall das Modul (und deaktiviere es wieder). Damit treten dann keine Abstürze auf.

    Von meiner Seite könnte damit die Anforderung auch wieder gelöscht werden. Oder der Workaround hier irgendwo als Lösung verschoben werden.

    Grüße

    Jens Kügl

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.