Startseite Foren Map Edit MapEdit Professional / AppBuilder / AutoCAD: Erstellen von Punktsymbolen

Ansicht von 1 Beitrag (von insgesamt 1)
  • Autor
    Beiträge
  • Fabian Finkbeiner
    Teilnehmer
    Beitragsanzahl: 7

    Insgesamt umständliche Erstellung von Punktsymbolen aus AutoCAD Map 3D raus (bzw. CorelDRAW und dann AutoCAD) für Postgre-Mapserver-Karten in ME Professional (später auch für ME Desktop) und teilweise fehlerhafte Darstellung dieser:

    Diese Punkte habe ich damals so an den MuM-Support geschickt:
    1. Wenn ich merke, das Fehler bzgl. Blocksymbol aus AutoCAD Map 3D besteht, entwerfe ich dort Neues mit selbem Blocknamen (da ich diesen ja benötige; ist in LAYER-Datei von AutoCAD_Map-Vorlagedateien
    (Darstellungsmodell) so vordefiniert)
    –> Bzgl. DWG mit allen Symbolen entferne ich dann fehlerhaftes Symbol u. füge dann neues Symbol ein
    –> Leider wird dieses neue Symbol mit altem Blocknamen, dann aber nicht so entsprechend im AppBuilder aktualisiert (sieht vom Layout her immernoch wie altes, fehlerhaftes Symbol aus)
    –> Daraus ergibt sich auch die Frage ob ich bestimmte Blöcke, die ich nicht mehr in der „MapEdit.msf“-Datei benötige, im AppBuilder löschen kann
    (u. zwar nicht nur über „Auswahl löschen“ in der msf-Datei unter „Symbol Dateien“ selbst, weil beim nächsten Aktualisieren der DWG mit allen Symbolen im Professional, hätte ich ja dann wieder die alten Blöcke,
    die ich dort zuvor rausgelöscht habe, in der msf-Datei drin)
    2. Kann ich auf besagte LAYER-Dateien auch im AppBuilder zugreifen u. dort diese bestenfalls auch abändern? (ansonsten wäre die Frage ob man die LAYER-Dateien zum Aktualisieren irgendwo im AppBuilder exportieren und
    importieren kann)
    – Da manche unserer Symbole denselben Namen wie bereits vorgefertigte MuM-Symbole haben, welche in „MapEdit.msf“ enthalten sind
    – Da manche unserer Symbole denselben Namen haben u. ich diese dann gerne in einer „CompositeRule“ einzeln erstellen würde mit jeweils unterschiedlichen Namen
    3. Symbol-Vorschau im Darstellungsmodell im AppBuilder fehlerhaft, z.B.
    – Im Stileditor abgeänderte Füllfarbe, Linienfarbe u. Drehung wird dort nicht angezeigt
    – Schwer einschätzbar wie groß Darstellung dann in ME Professional wird
    –> Welche Einheit wird bzgl. Breite u. Höhe verwendet?
    – Ausgegraute Linienstärke bzgl. Punktsymbolen –> Könnte aber dort auch hilfreich sein
    – Nach Füllfarbenabänderung von unserem Symbol in msf-Datei bzgl. Symbol Dateien: Füllfarbe wird teilweise nicht dargestellt
    – Muss ich bzgl. Breite u. Höhe immer 1 angeben oder kann ich Angaben so belassen?
    4. Symbol-Vorschau in ME Professional fehlerhaft
    – Füllfarbe wird nach Abänderung im Stileditor nicht übernommen (–> fehlt) u. Linienfarbe immernoch in schwarz, obwohl z.B. in Stileditor in rot abgeändert
    – Nach Reinladen von unserem Symbol:
    – Verzerrte Darstellung von Symbol sobald bzgl. Breite u. Höhe im Stileditor nicht 1 angegeben wurde
    – Füllfarben fehlen
    – Linienfarbe muss ich in Professional mit Befehl „Layer“ ggf. entsprechend anpassen, da dort automatisch bestimmte Farbe zugewiesen wird, die nicht unbedingt mit der aus msf-Datei bzw. Stileditor übereinstimmen
    muss

Ansicht von 1 Beitrag (von insgesamt 1)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.